Questions and Answers

My display does not appear to be working in standby!

This answer applies to R1 Mk3 R2 Mk3 R4 Mk3 R7 Mk3

​If this is the case, please check that the display has not been set to ‘Off’ when in standby mode. You can check this by pressing the menu button on the RotoDial control and then use the volume/selector knob to scroll through to System. Click the volume/selector knob to select System and then scroll through to Brightness. Here you will find two options for ‘On Level’ and ‘Standby Level’. Select ‘Standby Level’ and ensure that ‘Off’ or ‘0’ has not been selected.


Did this answer your question?

If not, please do not hesitate to contact us directly on +44 (0)1702 601410 or by using the enquiry form on our contact page.