Questions and Answers

I am experiencing Bluetooth connection problems with my Apple Mac computer. What can I do?

This answer applies to R1 Mk3 R2 Mk3 MR1 Mk1 MR1 Mk2 R7 Mk1 R7 Mk3

This is usually a symptom of the standard settings on the Mac computer. By default OSX has a low bitrate for Bluetooth audio, but for a good quality transmission, a value of between 40 and 58 should be used. You can edit and rectify this in two ways:

Terminal (quickest method)

Open up the terminal and type the following command:

defaults write com.apple.BluetoothAudioAgent “Apple Bitpool Min (editable)” -integer 45

You may need to precede this command with ‘sudo’ depending on your account settings:

sudo defaults write com.apple.BluetoothAudioAgent “Apple Bitpool Min (editable)” -integer 45

UI

1. Click the Bluetooth icon on the menu bar (top right near the clock).
2. Select “Open Bluetooth Explorer…”.
3. Once open, select “Utilities” (top left) and then “Special options”.
4. Increase the minimum bitpool to 40 and the maximum bitpool to 58.
5. Make sure that “Allow role switches for audio connections” is ticked.

Important: After using either method you will need to turn Bluetooth off and on again for the changes to take effect.


Did this answer your question?

If not, please do not hesitate to contact us directly on +44 (0)1702 601410 or by using the enquiry form on our contact page.